A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2025 - 14:00 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 14, 2025 - 10:57 EST
Update
Please be advised that CCDA Query and Retrieve is also impacted by this unexpected downtime.
We continue to work with our technology vendor to investigate the problem in order to resolve it urgently.
Posted Nov 14, 2025 - 09:17 EST
Investigating
Hello,
Please note that we are currently experiencing an unexpected downtime following scheduled maintenance.
We are working with our technology vendor to investigate the problem in order to resolve it urgently. The known impact to each live solution is listed below. We apologize for any inconvenience.
Community Health Record (CHR): You may experience errors within navigation
Notify: You may experience delays to receive notifications
Clinical Dispatcher: You may experience delays to receive notifications
Results Delivery: You may experience delays to receive results
Posted Nov 14, 2025 - 09:05 EST
This incident affected: Community Health Record (CHR), Notify, Results Delivery (Provider Routed), Clinical Dispatcher, Continuity of Care Document (CCD) - Query, and Results Delivery (MRN Routed).